HomeLatest ThreadsGreatest ThreadsForums & GroupsMy SubscriptionsMy Posts
DU Home » Latest Threads » Forums & Groups » Main » Community Help (Forum) » Avatar problem

Fri Apr 9, 2021, 11:32 AM

Avatar problem

My Avatar disappeared (one I uploaded). A blank (broken image) square shows instead. So I changed to one of the images from the DU list. Still just a blank. No big deal, so I clicked "I don't want to use an avatar" , but that blank box persists. How can I either get an avatar back, or not have an empty avatar box at all?

Thank you.

22 replies, 1098 views

Reply to this thread

Back to top Alert abuse

Always highlight: 10 newest replies | Replies posted after I mark a forum
Replies to this discussion thread
Arrow 22 replies Author Time Post
Reply Avatar problem (Original post)
edhopper Apr 9 OP
Backseat Driver Apr 9 #1
edhopper Apr 9 #2
h2ebits Apr 10 #3
quaint Apr 10 #4
h2ebits Apr 10 #5
edhopper Apr 11 #6
Make7 Apr 12 #7
edhopper Apr 12 #8
Make7 Apr 13 #9
edhopper Apr 13 #10
question everything Apr 17 #11
edhopper Apr 17 #12
question everything Apr 17 #13
edhopper Apr 18 #14
Pinback Apr 22 #15
edhopper Apr 22 #16
Pinback Apr 22 #17
edhopper Apr 22 #18
edhopper Apr 22 #19
question everything Apr 23 #20
edhopper Apr 23 #21
llashram May 5 #22

Response to edhopper (Original post)

Fri Apr 9, 2021, 12:58 PM

1. I got the same thing going on!

I clicked on it, and it jumped to a page of my Journal...?????

Reply to this post

Back to top Alert abuse Link here Permalink


Response to Backseat Driver (Reply #1)

Fri Apr 9, 2021, 02:03 PM

2. I checked

that happens to me as well. Must be a glitch

Reply to this post

Back to top Alert abuse Link here Permalink


Response to edhopper (Original post)

Sat Apr 10, 2021, 12:16 PM

3. I am having the same problem

My avatar disappeared and has been replaced with a box that, if clicked on, goes to my profile page--or says "view profile." I am unable to remove it or replace it with an avatar.

Reply to this post

Back to top Alert abuse Link here Permalink


Response to h2ebits (Reply #3)

Sat Apr 10, 2021, 01:48 PM

4. When I click on your piano avatar I'm taken to your journal.

Reply to this post

Back to top Alert abuse Link here Permalink


Response to quaint (Reply #4)

Sat Apr 10, 2021, 02:41 PM

5. I do not see any actual avatar for myself--only a block that is a "view profile"

And, when I click your response, I do not see your avatar just the words "View Profile"

Thanks for the input. Perhaps we are a step closer in figuring out what the problem is.

Reply to this post

Back to top Alert abuse Link here Permalink


Response to edhopper (Original post)

Sun Apr 11, 2021, 09:44 AM

6. Now I see everyones Avatar here but mine,

should I contact the Admin about this?

Reply to this post

Back to top Alert abuse Link here Permalink


Response to edhopper (Reply #6)

Mon Apr 12, 2021, 01:54 PM

7. The html source code loads the logged in user's avatar from 'upload.democraticunderground.com'...

... but other people's avatars from whatever domain the browser page is using (typically 'www.democraticunderground.com'). I think they did that to speed up custom avatars showing up after members uploaded them.

https://www.democraticunderground.com/avatars/jfk.gif


https://upload.democraticunderground.com/avatars/jfk.gif


The html also shows that avatar images are coded to be links to members' journals (clicking on the image takes you to their journal page).

Other people should be seeing your avatar just fine - any issue seems to be people not seeing their own avatar. You can double check the image that should be shown by either copying the image address and editing it to 'www' instead of 'upload' and opening it, or by viewing one of your posts in a browser where you are not logged in to DU.

Reply to this post

Back to top Alert abuse Link here Permalink


Response to Make7 (Reply #7)

Mon Apr 12, 2021, 03:05 PM

8. Thanks

I understand what you are saying as far as the code.Where can I change the image location. Under Edit Avatar DU only seems to let you pick an image, not put in an image location.

Reply to this post

Back to top Alert abuse Link here Permalink


Response to edhopper (Reply #8)

Tue Apr 13, 2021, 04:06 PM

9. Members that donate can upload custom avatars.

https://www.democraticunderground.com/star

Others are limited to choosing an avatar from the selection offered.

Custom avatars are stored on the DU servers after being uploaded.

When browsing DU, avatars images are loaded from the same domain as the page you are viewing - except for a signed in member's avatar image, those come from 'upload.democraticunderground.com'. That is the way the software is coded, the user does not have an option.

If you wanted to see what happens with other avatar images when using 'upload.democraticunderground.com', you can just view threads under that domain. For example:

https://upload.democraticunderground.com/125618409

Avatars seem to be working fine for me. It sounds like a browser related issue - force loading a page from the network may resolve it if it's a caching issue. I just posted to point out why seeing one's own avatar here can differ from viewing other people's or them viewing yours.

Reply to this post

Back to top Alert abuse Link here Permalink


Response to Make7 (Reply #9)

Tue Apr 13, 2021, 05:40 PM

10. Okay

Thanks.

Reply to this post

Back to top Alert abuse Link here Permalink


Response to edhopper (Original post)

Sat Apr 17, 2021, 10:32 PM

11. Same problem. Are you using Firefox? Is this what you see?



Reply to this post

Back to top Alert abuse Link here Permalink


Response to question everything (Reply #11)

Sat Apr 17, 2021, 10:41 PM

12. Yes

it seems it might be a problem with Firefox.

Reply to this post

Back to top Alert abuse Link here Permalink


Response to edhopper (Reply #12)

Sat Apr 17, 2021, 10:53 PM

13. Except that it was not until the recent "problem fixing"

Reply to this post

Back to top Alert abuse Link here Permalink


Response to question everything (Reply #13)

Sun Apr 18, 2021, 08:59 AM

14. it happened

about a day before I started this thread.

Reply to this post

Back to top Alert abuse Link here Permalink


Response to edhopper (Reply #12)

Thu Apr 22, 2021, 03:53 PM

15. Also a problem in Brave browser.

But when logged in to DU in Safari I can see my avatar just fine. Odd.

It may have something to do with cookies or adblock settings. I have less security in my copy of Safari, because I use it for sites that are broken in Brave.

Reply to this post

Back to top Alert abuse Link here Permalink


Response to Pinback (Reply #15)

Thu Apr 22, 2021, 03:58 PM

16. Also happens

on Opera for me. I'll play with adblock to see if that is it.

Reply to this post

Back to top Alert abuse Link here Permalink


Response to edhopper (Reply #16)

Thu Apr 22, 2021, 05:10 PM

17. After logging in to Firefox, I do see my avatar there.

There's a slash through the shield next to the URL field at the top, and when I click on that I see "Enhanced tracking protection is OFF for this site." So I guess at some point I was having problems with DU and safe-listed the site. I'd forgotten this, since I don't use Firefox much any more -- because it won't remember my search engine preferences from one session to the next. (It's always something!)

There's also a Privacy Protection setting in Brave. When I disabled that for DU, I was again able to see my avatar when logged in. BUT, oddly enough, when I then re-enabled Privacy Protection for this site, I could still see my avatar. (Maybe it's cached -- probably so, now that I think of it.)

I'll post an update when I have more information, if any.

Reply to this post

Back to top Alert abuse Link here Permalink


Response to Pinback (Reply #17)

Thu Apr 22, 2021, 06:31 PM

18. Thanks

Reply to this post

Back to top Alert abuse Link here Permalink


Response to Pinback (Reply #17)

Thu Apr 22, 2021, 07:53 PM

19. When I turned off Adblocker for Firefox

the Avatar reappeared. Seems that is the problem.

Reply to this post

Back to top Alert abuse Link here Permalink


Response to edhopper (Reply #19)

Fri Apr 23, 2021, 12:27 PM

20. Same here. I removed the uBlock and the problem disappeared

But then I started seeing ads on other sites, so I followed the advice here and installed AdGuard and so far so good.

Reply to this post

Back to top Alert abuse Link here Permalink


Response to question everything (Reply #20)

Fri Apr 23, 2021, 02:40 PM

21. I have UBlock

and was able to white list DU and leave it on for other sites.

Reply to this post

Back to top Alert abuse Link here Permalink


Response to edhopper (Original post)

Wed May 5, 2021, 12:21 PM

22. okay

power is out in the neighborhood. Thanks. Just wondering what happened to avatar...

Reply to this post

Back to top Alert abuse Link here Permalink

Reply to this thread