HomeLatest ThreadsGreatest ThreadsForums & GroupsMy SubscriptionsMy Posts
DU Home » Latest Threads » Forums & Groups » Main » The DU Lounge (Forum) » I began having problems w...
Introducing Discussionist: A new forum by the creators of DU

Wed Mar 5, 2014, 07:48 PM

I began having problems with my new toy Grand Prix's transmission

so we started digging in.
Turns out the last owner tried to rebuild the trans himself and forgot to put the seals in it...bad bad news

While we were rebuilding we changed the trannie gearing a little for more torque.

My OMG WTF moment became an upgrade on the cheap...

We upgraded the torque in a huge way.....cost me 475

I would imagine this 6 cylinder will go sub 12 in the 1/4 now

Not bad for a stock engine v6 with just air intake and chip and gearing work

2 replies, 213 views

Reply to this thread

Back to top Alert abuse

Always highlight: 10 newest replies | Replies posted after I mark a forum
Replies to this discussion thread
Arrow 2 replies Author Time Post
Reply I began having problems with my new toy Grand Prix's transmission (Original post)
backwoodsbob Mar 2014 OP
jakeXT Mar 2014 #1
backwoodsbob Mar 2014 #2

Response to backwoodsbob (Original post)

Wed Mar 5, 2014, 07:55 PM

1. No damage without oil ?nt

Reply to this post

Back to top Alert abuse Link here Permalink


Response to jakeXT (Reply #1)

Wed Mar 5, 2014, 08:00 PM

2. oh yeah it was damaged

said in the post...* the rebuild*

Reply to this post

Back to top Alert abuse Link here Permalink

Reply to this thread